LyZ 2.1.4 – Zotero Standalone

LyZ seems to work just fine with the new Zotero Standalone 3.0b1. I’ve tested it lightly on Linux only, so please use with caution and let me know what does not work. I will try to find time soon and get it working.

To install, open Zotero Standalone, go to Tools > Addons and click on the „mixer“ icon on top and click „Install Add-on from file..“ and choose the downloaded lyz-2.1.4.xpi.

Download lyz-2.1.4.xpi

18 comments to LyZ 2.1.4 – Zotero Standalone

  • Neat add-in, but missing directions. What should we put in for „Lyx Server“?

  • Petr

    Adam,
    do you mean lyx server path? See the installation and settings. Hope that helps

  • MH Werner

    thanks so much for developing lyz, it’s a really helpful program!

  • […] Here, you can download the plug-in and here, you can find some information on how to use it. To install it in Zotero standalone: 1. Open Zotero standalone. 2. Go to Tools > Addons and click on the „mixer“ icon on top 3. Click „Install Add-on from file..“ 4. Choose the downloaded lyz-2.1.4.xpi. […]

  • Hi,
    I install LyZ in my Zotero standalone. It works fine but there is a problem with the graphic, that is the plug-in changes the color of tool-bar of my zotero standalone. Here https://twitter.com/a_mazzamauro/status/216843210989907968/photo/1, you can see a screenshot showing that problem. Is it something that has already happened or is a problem of my personal device?
    Thank you
    Alfredo

  • […] 0) Assuming you already have lyx and zotero standalone, now download and install the plugin from http://www.klubko.net/wp/?p=1638. 1) set the pipe in lyx: tools/preferences/paths. In linux this has to be set to [home […]

  • […] faut préalablement télécharger un module d’export et l’installer dans Zotero. On se retrouve alors avec un bouton permettant d’exporter […]

  • Stefan

    Hi there

    for the third time in a couple of months I try to get Lyz working on Windows 7 with a portable version of Lyx but I am unable to find the correct settings for the the lyxserver and lyxpipe in Lyx and Zotero standalone. They simple don’t find each other. Admittedly, I don’t have a clue what the pipe/server instructions are supposed to do.

    I do not get beyond the error „Wrong path to Lyx server. Set the path specified in Lyx preferences.“ when I click on the „Cite in Lyx“ command. Some instructions for a simple minded person would be very welcome!

    Thank you – Stefan

  • Petr

    Hello Stefan,
    not sure how else to explain it in any other way, it seems quite straightforward.
    1. copy this string: \\.\pipe\lyxpipe
    2. in Lyz settings where it says Lyx Server, make sure that the string is there (it should be)
    3. in Lyx, go to Tools/Preferences/Paths and paste the string there
    Restart Lyx.
    That should do it. Good luck

  • Stefan

    Hi Petr

    thanks for getting back. I have been using exactly these instructions previously (and many variations of it).

    Here’s some unexpected progress though: I have two versions of LyX; an old unused one (1.6.5) on the C drive (where ZS is installed) , and a newer one (2.0.1) living on the D drive. Both LyXes are portable versions and used their own portable MikTex versions.

    For a change, I tried the old one, and LyZ works like a charm asking me whether I want to create a new bitex file etc – inserting references is fine.

    Now I wonder whether my problem has to do with
    – either the version 2.0.1
    – or the fact that that Zotero and LyX reside on different drives?

    Any idea? Thank you in advance.

    Stefan

  • Petr

    Hello Stefan,
    honestly, I have no idea. Perhaps it would be worthwhile to try the new LyX from C, since you say you are using portable version.
    I don’t use LyX any more and thus am quite out of the loop and I am actually heading out cruising for a while (see the beutiful boat on the header ;)) and I won’t be frequently online.
    The maintenance of LyZ has been taken over by a good soul at https://github.com/willsALMANJ/lyz
    Good luck, sorry I couldn’t be of more help
    Petr

  • JR

    Hello!

    Does it work for Lyx in Mac?

    Regards,
    JR

  • Al

    Hi there,

    It seems that LyZ does not work with the latest version of ZS (4.0). I try to install the plugin using the instructions you gave but ZS reports an error that the add-on may be incompatible. Is there any chance that his could be fixed?

    -Al

  • […] Here, you can download the plug-in and here, you can find some information on how to use it. To install it in Zotero standalone: 1. Open Zotero standalone. 2. Go to Tools > Addons and click on the „mixer“ icon on top 3. Click „Install Add-on from file..“ 4. Choose the downloaded lyz-2.1.4.xpi. […]

Napsat komentář k Al Zrušit odpověď na komentář